Inaccessible stores
Incident Report for Textalk Webshop
Resolved
The issue has been completely resolved.
Posted Mar 07, 2017 - 22:02 CET
Monitoring
The issue has been resolved and we are monitoring the system.
Posted Mar 07, 2017 - 21:35 CET
Investigating
We currently have a temporary disruption. More info soon
Posted Mar 07, 2017 - 21:29 CET