Customer service not avaliable via telephone
Incident Report for Textalk Webshop
Resolved
Issue is resolved. We can now receive calls again
Posted Nov 29, 2017 - 10:32 CET
Identified
Our telephone provider has technical issues. Estimated to be solved within 10 minutes
Posted Nov 29, 2017 - 10:28 CET
Investigating
We are currently experiencing issues with our telephone system and cannot recieve calls.
Please use email to reach customer service.
Posted Nov 29, 2017 - 10:20 CET