Prices not showing on articles
Incident Report for Textalk Webshop
Resolved
The issue has now been solved and we are monitoring the results.
Posted Dec 21, 2017 - 10:42 CET
Investigating
We are currently experiencing an issue where prices aren't showing up on articles.
Other issues can also occur due to this.

We are investigating and working on solving this as fast as possible.
Posted Dec 21, 2017 - 10:39 CET