All themes down
Incident Report for Textalk Webshop
Resolved
System is up again.
Posted Mar 25, 2017 - 19:00 CET
Identified
We have found the problem. Fix is being prepared
Posted Mar 25, 2017 - 18:40 CET
Investigating
We are currently investigating this issue.
Posted Mar 25, 2017 - 18:05 CET